Forums Gallery Downloads LOGIN |REGISTER

Playing back a video cutscene

If you're looking for help with Scaleform, HUD development, UI Emulator/Actions, this is the place!


 

lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Playing back a video cutscene

Postby lachjames » 11.07.2012, 06:11

Hi everyone,

I'm working on a project and I'm trying to get webm video playback using the plugin on the projects page. I'm having trouble getting it working though.

The trouble is that I don't really understand exactly how it works. Does it convert every instance of a certain material into a video texture? Is there any way to have fullscreen video playback and not as a texture on an object?

I've been struggling with this for a while and I'm getting no-where (I do have a rather limited understanding of game development though).

Thanks for any clarifications that could be given,

Lachjames
User avatar
Lavizh
News Posters
News Posters
 
Posts: 12077
Member since: 04.12.2007, 03:23
Location: Hamar, Norway
Likes: 750

Re: Playing back a video cutscene

Postby Lavizh » 11.07.2012, 07:54

You are using hendrikp's videoplayback plugin? Isn't there an example level or readme file that came with it?
 
 
Image
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 12.07.2012, 06:10

Hey thanks for the reply,

I'm trying to understand the readme and examples but they aren't making sense to me - is there any way to play videos in full screen on the player's computer?

Thanks for your assistance :)
User avatar
Lavizh
News Posters
News Posters
 
Posts: 12077
Member since: 04.12.2007, 03:23
Location: Hamar, Norway
Likes: 750

Re: Playing back a video cutscene

Postby Lavizh » 12.07.2012, 06:38

Yes i believe so, there are splashscreen examples there, just edit the appropriate xml file. or do you want ingame videos? if so just look at how hendrikp did his FlowGraphs in his example level.

There is a node that can play back videos at X,Y. I don't have the editor infront of me now.
 
 
Image
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 12.07.2012, 07:45

Thanks for that, Lavizh.

I'm not at my pc now but I'll take a look as soon as I get home.

Thanks for your help.
User avatar
hendrik
Producer
Producer
 
Posts: 1326
Member since: 29.05.2010, 11:46
Location: Germany
Likes: 163

Re: Playing back a video cutscene

Postby hendrik » 12.07.2012, 18:15

Use the InputWebM and Output2D flowgraph node and leave width and height 1 (1 means fullscreen, 0.5 half of the screen). (connect videoid,show, hide)

see here:
Image

And the splashscreen should already be playing automatically using the xml playlists.

There should be people using it so maybe someone can post a more extensive sample, I will make more video tutorials as I find time.
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 13.07.2012, 07:20

Thanks for that Hendrikp.

The audio is working but the video doesn't show - I think it may be a format issue so I'm going to keep fiddling and converting and hopefully try to get it working.

I'll let you know if I get it work, or if I need some extra help with it.

Thanks
User avatar
Lavizh
News Posters
News Posters
 
Posts: 12077
Member since: 04.12.2007, 03:23
Location: Hamar, Norway
Likes: 750

Re: Playing back a video cutscene

Postby Lavizh » 13.07.2012, 08:23

You did remember to split audio from the video file?
 
 
Image
User avatar
hendrik
Producer
Producer
 
Posts: 1326
Member since: 29.05.2010, 11:46
Location: Germany
Likes: 163

Re: Playing back a video cutscene

Postby hendrik » 13.07.2012, 11:57

Try using X-Media Recode its free for the video only webm/v8 is supported (I show it in the video).
Also try to have the resolution divisible by 16.

Are you sure you connected the Show input of the Output 2d node and that the alpha is not set to transparent? (also let customheight/width be -1 only modify fheight/fwidth in output2d)

The splashscreen videos are playing,yes if not then there is a general problem. (Also try maybe first simply replacing one of the sample videos).
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 31.08.2012, 05:14

Thanks for your help guys,

I'm still having a bit of trouble with it though. The audio plays fine but the video doesn't - even with it set up exactly as you said (with only an input node connected to a 2D playback node, with the settings all the same).

What I'm trying to do is play a video file in fullscreen as a pre-rendered cutscene.

EDIT: Oh, and I downloaded the update and took a look at the sample game file you added and a lot of the flowgraph nodes are listed as "missing". Does that mean anything bad?

EDIT #2: Facepalm time. Turns out I didn't have the plug-in installed properly! Thanks for your help guys - the plug-in's great!
User avatar
hendrik
Producer
Producer
 
Posts: 1326
Member since: 29.05.2010, 11:46
Location: Germany
Likes: 163

Re: Playing back a video cutscene

Postby hendrik » 03.09.2012, 18:02

np any idea how to improve the documentation on plugin installation, what exatcly was misunderstood? You are not the first one having trouble *installing* it.
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 05.09.2012, 03:13

Hi Hendrikp,

The main thing with the documentation is that it would be helpful to perhaps release an updated guide to using it with the new features and structure. Also, a written step-by-step guide would be useful to accompany the video's tips for installation, to clarify exactly what is supposed to be done. If there's anything I can do to help out, let me know.

Edit: Oh, also, now that I think about it, it would be good if you could make it clear that the content pack doesn't include the actual plugin as well as the content (I had to learn that the hard way - I'm sure you've said it somewhere but I never read it and I just assumed that the content pack was some form of "enhanced" version of the plug-in).
lachjames
Just getting started
Just getting started
 
Posts: 11
Member since: 26.12.2011, 06:56
Likes: 0

Re: Playing back a video cutscene

Postby lachjames » 18.09.2012, 13:45

Hi again Hendrikp,

I'm having another problem now where the videos play back properly in the editor but show only a pure white screen in the launcher. I've tried messing with the settings but I'm stumped on what it could be.

Thanks for any help,

Lachjames

EDIT: The problem only occurs in the 32bit launcher.
User avatar
hendrik
Producer
Producer
 
Posts: 1326
Member since: 29.05.2010, 11:46
Location: Germany
Likes: 163

Re: Playing back a video cutscene

Postby hendrik » 18.09.2012, 15:12

lachjames wrote:Hi again Hendrikp,

I'm having another problem now where the videos play back properly in the editor but show only a pure white screen in the launcher. I've tried messing with the settings but I'm stumped on what it could be.

Thanks for any help,

Lachjames

EDIT: The problem only occurs in the 32bit launcher.


yes its in the release notes, launcher 32bit+DX11 combination has only support for splahscreens/menus not for ingame video. (this is limitation since 32bit dx11 launcher isnt stable)


 
Connect and collaborate with CRYENGINE developers in the official Forums.
Visit the Gallery to share what you have created and be inspired by what others are creating with CRYENGINE.
Community