Forums Gallery Downloads LOGIN |REGISTER

CryEngine no longer working with my Graphics card

If you have problems with the Sandbox editor or other provided tools, let us know here.


 

HWJohn
Just getting started
Just getting started
 
Posts: 77
Member since: 10.10.2011, 23:29
Likes: 0

CryEngine no longer working with my Graphics card

Postby HWJohn » 07.07.2012, 05:48

For some reason, CE3 keeps crashing whenever I try to load forest.cry or use the launcher. Whenever I use the launcher, I get a graphics card not supported error. But according to the website and past experiences, my card should work fine.


The Card is an ATi 5870

I think it may be driver issues, due to my CCC not even opening, but I've reinstalled it several times already and nothing has changed.
User avatar
twitchythumbs
Junior Dev
Junior Dev
 
Posts: 149
Member since: 19.05.2012, 04:47
Location: Santa Cruz, California
Likes: 1

Re: CryEngine no longer working with my Graphics card

Postby twitchythumbs » 07.07.2012, 09:35

That card is decent, its probably a driver issue. Is anything else not working? (i have no idea what CCC stands for)

BTW, I stay away from ati for that exact reason. Their software, support and drivers are a total joke compared to Nvidia.

get a GTX 580, better picture quality too due to things like physx

Its a bit more expensive for the same specs, but you get what you pay for.
HWJohn
Just getting started
Just getting started
 
Posts: 77
Member since: 10.10.2011, 23:29
Likes: 0

Re: CryEngine no longer working with my Graphics card

Postby HWJohn » 07.07.2012, 23:52

CCC stands for Catalyst Control Center, it's pretty much the Control panel.

For NVidia, I wish I could get one, but I can barely afford my computer as it is, so I can't.
User avatar
VokusX
Not my first Rodeo
Not my first Rodeo
 
Posts: 523
Member since: 18.08.2011, 15:08
Location: Canada
Likes: 2

Re: CryEngine no longer working with my Graphics card

Postby VokusX » 08.07.2012, 00:50

Might be a bit off-topic, but with these "stable" drivers that ATI offers, I managed to get 3 BSODs in one day.
[1:49:53 PM] fedayk1ntr: Join the Dark side
[1:50:04 PM} themodman101: You may have cookies, but we have all the milk.
HWJohn
Just getting started
Just getting started
 
Posts: 77
Member since: 10.10.2011, 23:29
Likes: 0

Re: CryEngine no longer working with my Graphics card

Postby HWJohn » 08.07.2012, 01:14

Yeah, the joke is ATi has no drivers while NVidia causes house fires.


I just wanna continue learning with CE3, but this damn thing won't even load the map. I do believe it's the drivers, because it tells me the drivers crashed and rebooted. When I map a whole new map, it seems to work. Is there any third-party drivers?
User avatar
Ruan
Has seen it all
Has seen it all
 
Posts: 11740
Images: 0
Member since: 11.07.2008, 20:25
Location: Nottingham, UK
Likes: 90

Re: CryEngine no longer working with my Graphics card

Postby Ruan » 08.07.2012, 02:44

Seen the AMD card sticky? ;) viewtopic.php?f=326&t=88499
Out now! CryENGINE Game Programming with C++, C#, and Lua
Ex-Crytek, now with Deep Silver Dambuster Studios
HWJohn
Just getting started
Just getting started
 
Posts: 77
Member since: 10.10.2011, 23:29
Likes: 0

Re: CryEngine no longer working with my Graphics card

Postby HWJohn » 08.07.2012, 04:31

I honestly didn't. Thank you! I hope a fix comes out soon.


 
Connect and collaborate with CRYENGINE developers in the official Forums.
Visit the Gallery to share what you have created and be inspired by what others are creating with CRYENGINE.
Community