Forums Gallery Downloads LOGIN |REGISTER

Problem with New Smart Objects Behaviour !!!

Gameplay Setup, SP/MP Logic, Audio Setup, AI Logic, Entity Usage, etc.


 

User avatar
fran.mts
Just getting started
Just getting started
 
Posts: 53
Member since: 17.08.2009, 21:25
Location: Brazil
Likes: 0

Problem with New Smart Objects Behaviour !!!

Postby fran.mts » 11.03.2012, 08:06

Hi folks! :cheesy:

I'm having a really bad time trying to learn this SmartObjects section... I believe Crydev's FreeSDK Documentation for Setting Up a New Smart Objects Behaviour still has some gaps.

In the first example I did everything as the tut says... but then when I need to create a new Action it doesn't work.. doesn't create!! I tried creating the FlowGraph for the Explosion Entity another way, as can be seen on the pic as well, but nuthing happened... no explosion =( very disappointing..

I can also tell that I've tried to follow the SECOND EXAMPLE AND THERE IS ALSO THE SAME GAP...
I followed the tutorial step by step and then I came to the point where the ActionNames "pickupobject" and "putdownobject" are simply not available in the FreeSDK.. alright, so then I tried to create those AI Actions... and the editor doesn't lists the brand new xml files created for the new AI Action (either in the list or in the FlowGraphs!!!!) :mad:

Has someone ever followed this tut and got these 2 examples working???

THXXX IN ADVANCE!
Attachments
New SmartObject problem.png
New Smart Object problem
AndOrXor
Junior Dev
Junior Dev
 
Posts: 178
Member since: 19.08.2011, 10:04
Location: Prague, Czech Rep.
Likes: 1

Re: Problem with New Smart Objects Behaviour !!!

Postby AndOrXor » 11.03.2012, 19:33

I believe youre saving AI Action xml into wrong path, thats why your files are not loaded and accesible. Path is listed in documentation
User avatar
fran.mts
Just getting started
Just getting started
 
Posts: 53
Member since: 17.08.2009, 21:25
Location: Brazil
Likes: 0

Re: Problem with New Smart Objects Behaviour !!!

Postby fran.mts » 12.03.2012, 00:13

Indeed, I was saving in the wrong path, it should be in "Game/Libs/ActionGraphs"... then it started exploding! Thx a lot AndOrXor!!!
AndOrXor wrote:I believe youre saving AI Action xml into wrong path, thats why your files are not loaded and accesible. Path is listed in documentation


But for the second example I still haven't had success... I uploaded 3 new pics showing what I did so far... I'm not really sure how to setup the Flowgraphs for "pickupobject" and "putdownobject"... could anyone please help on that?? Maybe the problem is here!

I think it's very close to the system start working, as the first picture shows the debug "wanting" to grab the box, but the worker don't go... :sad:
Attachments
Worker.png
CrateDelivery.png
PickUpCrate.png
AndOrXor
Junior Dev
Junior Dev
 
Posts: 178
Member since: 19.08.2011, 10:04
Location: Prague, Czech Rep.
Likes: 1

Re: Problem with New Smart Objects Behaviour !!!

Postby AndOrXor » 12.03.2012, 01:26

im afraid i have no good news. Pickup and putdown are not working :) you can just show message when picking, but not pick item at all. Anyway if someone know way how to pick item from ground or table with IK and giving into hand i would like to know that (not by track view), thanks :)
User avatar
fran.mts
Just getting started
Just getting started
 
Posts: 53
Member since: 17.08.2009, 21:25
Location: Brazil
Likes: 0

Re: Problem with New Smart Objects Behaviour !!!

Postby fran.mts » 12.03.2012, 02:21

Hey dude.. i found an AIGrabObject node.... I set up as said in the documentation but by no means the character even go to the position... I tried several times regenerating AI, cover sufraces, reentering physics mode, game mode, character auto-disable, ai_ignoreplayer.. nothing =//

Then I tried substituting the AIGrabObject for an AIGoto Node... and again he doesn't walk... I really have no idea where the problem is!!!

ANYONE PLEASEEEE!! this should be simple to accomplish since it's just an example from the Crydev's tutorials......... Would be really nice if someone uploaded a really basic level with this function working so we could see with our own eyes and find the problem!!!! :love:
Attachments
pickupobject.png
pickupobject
AndOrXor
Junior Dev
Junior Dev
 
Posts: 178
Member since: 19.08.2011, 10:04
Location: Prague, Czech Rep.
Likes: 1

Re: Problem with New Smart Objects Behaviour !!!

Postby AndOrXor » 12.03.2012, 12:00

fran.mts wrote:Hey dude.. i found an AIGrabObject node.... I set up as said in the documentation but by no means the character even go to the position... I tried several times regenerating AI, cover sufraces, reentering physics mode, game mode, character auto-disable, ai_ignoreplayer.. nothing =//

Then I tried substituting the AIGrabObject for an AIGoto Node... and again he doesn't walk... I really have no idea where the problem is!!!

ANYONE PLEASEEEE!! this should be simple to accomplish since it's just an example from the Crydev's tutorials......... Would be really nice if someone uploaded a really basic level with this function working so we could see with our own eyes and find the problem!!!! :love:

AFAIK position node doesnt work (for me) correctly. For testing dont use modules and AI actions. And as i said before, AIGrabObject dont work
User avatar
fran.mts
Just getting started
Just getting started
 
Posts: 53
Member since: 17.08.2009, 21:25
Location: Brazil
Likes: 0

Re: Problem with New Smart Objects Behaviour !!!

Postby fran.mts » 15.03.2012, 20:01

Really no one found a solution guys? =(

These smart objects are a really functional and important feature in the engine, which lets you create sophisticated entity behaviors with little effort, really would like to learn! =)

Would someone from crytek maybe please help?

Thanks..
AndOrXor
Junior Dev
Junior Dev
 
Posts: 178
Member since: 19.08.2011, 10:04
Location: Prague, Czech Rep.
Likes: 1

Re: Problem with New Smart Objects Behaviour !!!

Postby AndOrXor » 16.03.2012, 10:18

Im lost now, what problem exactly you have? I was experimenting with SO for long time and they are trully usable but i have some complains about it - not about functionality but how they are designed


 
Connect and collaborate with CRYENGINE developers in the official Forums.
Visit the Gallery to share what you have created and be inspired by what others are creating with CRYENGINE.
Community