Forums Gallery Downloads LOGIN |REGISTER

Breakable glass not working for me in 3.4.0?

Topics about 3DS Max, Maya, Photoshop, and various other software packages.


 

dovonob
Just getting started
Just getting started
 
Posts: 86
Member since: 10.11.2011, 03:08
Likes: 0

Breakable glass not working for me in 3.4.0?

Postby dovonob » 12.05.2012, 04:18

Hi

I've got a problem with breakable glass in 3.4.0, it works fine for me in the 3.3.9 version but for the life of me I can't work out why the same models arn't working in the new one.

In 3.3.9 i just set the material shader and surface type both to glass and it worked, in the new version there's a few different options of unbreakables for the surface type, no matter which _unbreakable type i use, the texture becomes invisible and when I shoot the glass i get the 'no surface type assigned' message. I can see from the shadow the glass is casting that it is breaking so I'm beyond confused what's wrong??

Is there any extra steps I should be doing in 3.4.0 to make breakable glass that I'm not aware of?

In terms of the setup of my object I've done it in 3d Max and just have a dummy node with a 'BreakGlass_01' child which is just a box shape modified into an editable poly.

Any advice would be much appreciated :)
User avatar
hungoverontues
Junior Dev
Junior Dev
 
Posts: 182
Member since: 05.07.2011, 06:10
Likes: 2

Re: Breakable glass not working for me in 3.4.0?

Postby hungoverontues » 13.05.2012, 02:06

I use solids for my glass, but have noticed certain shapes/thickness dont seem to break.
User avatar
NeoLegends
Producer
Producer
 
Posts: 1731
Member since: 21.10.2011, 23:50
Likes: 8

Re: Breakable glass not working for me in 3.4.0?

Postby NeoLegends » 13.05.2012, 20:01

I think the problem is the solids. Try using a brush with a glass material.
dovonob
Just getting started
Just getting started
 
Posts: 86
Member since: 10.11.2011, 03:08
Likes: 0

Re: Breakable glass not working for me in 3.4.0?

Postby dovonob » 14.05.2012, 10:54

Nope can't get it working for the life of me yet works everytime for me in 3.3.9.

I'm not using solids I was exporting from Max although i did try that aswell after reading hungoverontues comment, tried using a basic entity and a brush, same outcome. I can get it to work now without the 'no surface type assigned' error but still the texture is completely invisible, there's no opacity/alpha on the materials.

If i leave the shader as 'illum' i can see the texture until i shoot it then it disapears, with glass shader its always invisible.

I'm guessing no one else is having this problem which would leave me to believe its something i'm doing wrong but the fact i do the same steps and it works perfectly in the previous version is making my brain melt?

Sod it i'll make destructible objects for the glass panes instead otherwise I'm going to end up putting my head through my monitor :)
dovonob
Just getting started
Just getting started
 
Posts: 86
Member since: 10.11.2011, 03:08
Likes: 0

Re: Breakable glass not working for me in 3.4.0?

Postby dovonob » 08.06.2012, 13:24

Anyone who's interested, having the 'tint' variable in the shader params set to 255,255,255 makes the glass invisible, randomly figured that out yesterday whilst messing with different shader stuff.

Still doesn't break right though looks awful and still get the 'no surface type assigned' when shooting it even though it makes the bullet holes??!??!?!?

Swear this isn't working right in this version, is no one else having problems with breakable glass?
Keytay
Just getting started
Just getting started
 
Posts: 9
Member since: 27.06.2012, 09:13
Likes: 0

Re: Breakable glass not working for me in 3.4.0?

Postby Keytay » 28.06.2012, 13:50

yep i cant get it to work either. Get the 'no surface icon' with bullet holes as well.
Also I cant see it breaking at all.
I have some window attached to a house model and when i shoot out the glass the whole house disappears. Strange.
User avatar
the_grim
Superstar Dolphin
Superstar Dolphin
 
Posts: 9884
Member since: 16.08.2004, 10:46
Location: Finland
Likes: 189

Re: Breakable glass not working for me in 3.4.0?

Postby the_grim » 28.06.2012, 14:15

I think this is a confirmed bug in 3.4.0, the containers on the shore in the Forest level disappear too when shot at.
dovonob
Just getting started
Just getting started
 
Posts: 86
Member since: 10.11.2011, 03:08
Likes: 0

Re: Breakable glass not working for me in 3.4.0?

Postby dovonob » 29.06.2012, 12:44

bizarrely i got this to work the other day, well i say 'I' got it to work, I installed all the example assets:

dm_eds/files/General_Downloads/CryENGINE_PC_v3_3_9_3410_FreeSDK.zip

and there's a breakable glass example in there, that worked for me, the broken glass pieces didn't hang around for very long and it didn't particuliary look very good but it did work.

To be honest I don't know if it's just me but the deeper I delve into 3.4.0. the more it crashes in the most annoying of places. Crashes for me in the animation graph quite alot, having to save it everytime I make even the slightest change before making further changes in fear of it crashing out. The melee attack is causing some nice freezes if I change the damage value's aswell. Ah well fingers crossed they'll be an update soon.


 
Connect and collaborate with CRYENGINE developers in the official Forums.
Visit the Gallery to share what you have created and be inspired by what others are creating with CRYENGINE.
Community