Forums Gallery LOGIN |REGISTER

Community Archive is read-only - Here you can view content recorded up until February 2017. To join the latest discussions visit our new forums


voxel problems :/

Just getting started? Looking for some information on CE and/or CE projects? Ask here!


 

User avatar snorgy
Just getting started
Just getting started
 
Posts: 8
Member since: 09.09.2012, 21:29
Likes: 0

voxel problems :/

Postby snorgy » 12.09.2012, 21:14

Not sure if this is the right sub-category that i posted in, but i'm new so let it go please. :p

Anyway, i've been watching a bunch of tutorials on youtube on how to create a cave using voxel painter I created the cave, but now when I add any materials(textures) to the cave that i've created it just gets white, I changed the color, that's not the issue, I get some kinda error when painting. "[Error] Runaway thread 3950 tris, Share verts: (11850->2017), 3878 tris produced," is this why it won't change the color on the textures?


Thanks for helping a Noob like me. :P
User avatar snorgy
Just getting started
Just getting started
 
Posts: 8
Member since: 09.09.2012, 21:29
Likes: 0

Re: voxel problems :/

Postby snorgy » 12.09.2012, 22:51

it's like really really bright aswell, here's a picture.
Attachments
caveissue.JPG
really annoying :/
User avatar Kirkland
Just getting started
Just getting started
 
Posts: 4
Member since: 13.09.2012, 04:31
Likes: 0

Re: voxel problems :/

Postby Kirkland » 16.09.2012, 03:29

I'm really really new as well, but this might help you:
When you create a Voxel, make sure to set the SmartBaseColor Parameter to Yes.
You also need to create a Texture which you want to use for the Cave. I'm using materials/terrain/rock_4 for mine.
Once you have actually created your cave - Go to the voxel painter, make sure to choose the correct surface type at the bottom, and then brush the insides of your cave. I just used the Soft Create and Soft Subtract, but the material brush is probably the one you are supposed to use.
User avatar snorgy
Just getting started
Just getting started
 
Posts: 8
Member since: 09.09.2012, 21:29
Likes: 0

Re: voxel problems :/

Postby snorgy » 16.09.2012, 19:10

Thanks alot, but now there's like white lines in every edge kinda looks like a winter cave, and outside the "opening" is still white, i really appreciate the help you've given me tho.
User avatar Kirkland
Just getting started
Just getting started
 
Posts: 4
Member since: 13.09.2012, 04:31
Likes: 0

Re: voxel problems :/

Postby Kirkland » 16.09.2012, 22:25

Outside the opening there is usually a bit of gaps or something where the Voxel and the actual Terrain intersect. The white lines might be related. I'd probably play around with both the voxel painter and the terrain modify brushes. Add a little, subtract a little, see if the lines disappear.

On one hole that I made, after I was done I had "walls" of terrain thrown up - I ended up moving the voxel a little and it cleared it. I can't really explain it other than to say - fiddle around with it.
User avatar snorgy
Just getting started
Just getting started
 
Posts: 8
Member since: 09.09.2012, 21:29
Likes: 0

Re: voxel problems :/

Postby snorgy » 17.09.2012, 00:56

Thanks again, but apparently my cryengine privileges got locked, no idea why.



Time : 0.179s | 27 Queries | GZIP : Off